This problem relates to mime types, if you navigate there you will find a message reporting duplicate mime types. Please verify if your IIS application configuration file has the BizTalk360 section correctly setup (normally located under: C:\Windows\System32\inetsrv\config\applicationHost.config):


    <location path="Default Web Site/BizTalk360">

        <system.webServer>

            <security>

                <access sslFlags="Ssl, SslNegotiateCert, SslRequireCert" />

                <authentication>

                    <windowsAuthentication enabled="true" />

                    <anonymousAuthentication enabled="false" />

                    <digestAuthentication enabled="false" />

                    <basicAuthentication enabled="false" />

                </authentication>

            </security>

            <defaultDocument>

                <files>

                    <clear />

                    <clear />

                    <add value="Default.aspx" />

                </files>

            </defaultDocument>

            <staticContent>

                <remove fileExtension=".xbap" />

                <remove fileExtension=".xap" />

                <remove fileExtension=".xaml" />

                <mimeMap fileExtension=".xaml" mimeType="application/xaml+xml" />

                <mimeMap fileExtension=".xap" mimeType="application/x-silverlight-app" />

                <mimeMap fileExtension=".xbap" mimeType="application/x-ms-xbap" />

            </staticContent>

        </system.webServer>

    </location>


The remove instruction is the important piece here to avoid the duplicates. Make sure you enter this and reset iis to get your images working.