COM class factory for component with CLSID

You may face the below exception within BizTalk360


Description: Could not retrieve transport type data for Receive Location " " from config store. Retrieving the COM class factory for component with CLSID {CF3C637A-0D4E-47BD-9210-DB40A33BD488} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).


StackTrace: Microsoft.BizTalk.ExplorerOM.BtsException: Could not retrieve transport type data for Receive Location " " from config store. Retrieving the COM class factory for component with CLSID {CF3C637A-0D4E-47BD-9210-DB40A33BD488} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).


When you try to access the same with BizTalk Admin you face the same exception within BizTalk admin console where BizTalk360 is installed.


Here are the suggestions to solve this case:

1. SSO service components should be installed on the machine where BizTalk360 is installed(no need to configure SSO).

image


2. Check whether the connection is fine and it works between BizTalk360 and SQL Server machine using the DTCPing. To use DTCPing https://www.microsoft.com/en-us/download/details.aspx?id=2868

 

3. To manage and Troubleshoot SSO, follow the Enterprise SSO Survival Guide

https://social.technet.microsoft.com/wiki/contents/articles/6904.biztalk-server-2010-enterprise-sso-survival-guide.aspx

 

4. Check if a firewall or any other services are blocking which is related to WMI and MSDTC, enable all services which are related to MSDTC on all machines.

https://blogs.biztalk360.com/biztalk360-dependent-ports-protocols/ 


To troubleshoot problems with MSDTC please follow the below article

https://msdn.microsoft.com/en-us/library/aa561924(BTS.20).aspx

 

 5. The SSO and the Adapter pack what is installed in the BizTalk360 machine should be the same version what is installed in BizTalk server? 64 or 32 bit.

 

6. As a last try, install the run-time elements to get all the required files under the SSO folder and then remove the runtime feature by running the setup again.



Login or Signup to post a comment