Migration Issues - The version of BizTalk360 database you use is incompatible with the current UI application version

When migrating from BizTalk 2009 to BizTalk2010, our customer was facing this error message - 

The version of BizTalk360 database you use is incompatible with the current UI application version


 image


The customer had done all the correct steps.


The correct way is to first take a backup of BT360 database 
1. Deactivate licence
2. Upgrade BTS to new version
3. Uninstall BT360
4. Change the admin component installed on BT360 server to match that of the new BTS ver
5. Re-install the old ver of BT360 and map the old database to the new installed version as long as both the previous & re-installed version are same.

However still the error persisted.
We checked the BizTalk ver no in the database and made sure that was correct. 

Turns out the old environment (BizTalk2009) was not removed, prior to deactivation of licence and backup of database.

Hence the BT360 although on BTS2010 was still trying to connect to a BTS2009 server.

Make sure to remove your environment if you are no longer going to monitor it. If the old environment was also upgraded to BTS2010 this issue will not occur and no need to remove the environment.


When you installed BT360 previously, the version of the old BTS was stored in the database, this needs to be changed,


Kindly re-install the same version of BT360 as before after you have updated the admin components, and then point the fresh installation to the old database by changing the config files as described.



Login or Signup to post a comment